Markiert: Vagrant

Magento-Neuigkeiten #30

Die eigentlich in den letzten Monaten positiven Meldungen rund um Magento 2 wurden diese Woche von einer Ankündigung durch eBay überschattet: eBay Enterprise, zu dem auch Magento gehört, soll entweder an die Börse gebracht oder verkauft werden. Was bedeutet das für die Zukunft von Magento?

Das und mehr in den Magento-Neuigkeiten #30.

Weiterlesen …

Magento 2 Developer Beta installieren

Wer die Magento 2 Developer Beta ausprobieren will muss sicherstellen, dass seine Umgebung die Voraussetzungen erfüllt. Dazu zählt neben MySQL 5.6 bald auch PHP 5.5. Das hat bei weitem noch nicht jede/r Distribution/Provider/Entwickler verfügbar.

Um diesem Problem aus dem Weg zu gehen, entdecken gerade viele Beta-Teilnehmer Werkzeuge wie Vagrant und Docker für sich. So entstanden in letzter Zeit einige Skripte die eines der beiden Tools verwenden, um Entwicklern eine Magento-2-kompatible VM (Virtuelle Maschine) bereitzustellen.

Weiterlesen …

Installation / Provisionierung fertiger Vagrant-Boxen mit Puppet funktioniert nicht

Installation / Provisionierung fertiger Vagrant-Boxen mit Puppet funktioniert nicht

Als ich meine ersten Gehversuche mit Vagrant hatte (2011? 2012?), habe ich eine Reihe von fertigen Konfigurationen für Puppet (oder auch Chef) probiert. Das seltsame war: von denen haben die meisten nicht funktioniert. Einige liefen durch, andere wurden teilweise installiert, wieder andere gar nicht. Die Fehlermeldungen waren unterschiedlich.

Es hat ein wenig gedauert, bis ich den Grund verstanden hatte: apt-get update, also die Aktualisierung des Paket-Index, fehlt in den meisten Boxen und das hat bei 90% zu Problemen geführt.

Was kann man dagegen tun?

Weiterlesen …

Vagrant mit Shared-Folders in Windows: Fehlermeldung „invalid Unicode escape“

Vagrant mit Shared-Folders in Windows: Fehlermeldung „invalid Unicode escape“

Ich habe vor kurzem die Erzeugung von Vagrant-Konfigurationen und Puppet-Manifesten über die Website www.puphpet.com getestet.

Mit einer Konfiguration von PuPHPet erhielt ich beim ersten Start die Meldung:

D:\vagrant\ubuntu-1204-php-53>vagrant up
There is a syntax error in the following Vagrantfile. The syntax error
message is reproduced below for convenience:

D:/vagrant/ubuntu-1204-php-53/Vagrantfile:16: invalid Unicode escape
...m.synced_folder "D:\webserver\ubuntu-1204-php-53", "/var/www...
...                               ^

Weiterlesen …